We use cookies on our website to provide you with the best experience. If you continue browsing, you are consenting to our use of these cookies, but if you would like to know more, including how you can change your settings, take a look at our Privacy Notice.

Report Designer - How to add or remove text and variables in reports, layouts, letters and labels

When editing your documents in Report Designer, two of the most common elements you're likely to use are text boxes and variables.

  • Text box - This is text which is always the same on your document, for example, column headings on a report.
  • Variables - These extract information from your accounts data and display it on your report, for example, customer account references and names.

You can add or remove text and variables as required in most Sage Accounts documents.

Tip: In Sage Accounts 2013 (v19) and above, the Report Designer Dynamic Help takes you through adding adding text and variables step by step. You can check your version in Help > About > Program Details.

The following steps contain everything you need to help you add and remove text and variables. This article assumes that you've located the report or layout that you want to amend and opened it in Sage Report Designer. If you need further help with this, please refer to article 16965 .

Note: If any of the panes mentioned in this section aren't visible, open the View menu and select the required pane. If the pane doesn't appear, you can reset the Report Designer view to its default. For further information about this, please refer to article 27400.

To add text

Note: This section explains how to add new text to a document. To edit existing text, locate and select the required text box then press Enter. The cursor appears at the beginning of the text. Edit the text as required then click a blank area outside the text box.

  1. Report Designer > Toolbox menu > Add Text > click the area of the report where you want the new text to appear.

    Report Designer v1.3 and below - Toolbox menu > Textbox > click the area of the report where you want the new text to appear.

    Tip: You can check your Report Designer version in Help > About > Application > File Version.

  2. In the text object box, enter in the text that you want to appear on the report > click a blank area outside the text box.

    Note: The text object box expands as you type, or you can click and drag to specify the space needed by the text box.

You've now added text to your document and should make any further changes required to the document then save the changes. For further information about how to save the amended document, please refer to the section To save the changes to your document later in this article.

To add variables

  1. Report Designer > Variables pane > expand the table you require, for example, SALES_LEDGER > select the Variable you require, for example, ACCOUNT_REF.

    Tip: If you've chosen to auto-hide any of your Report Designer panes, the name appears in a tab to the left or right of your window. To expand a pane, click on its name.

  2. Drag the variable and drop it onto the design in the required position.

    Note: If Active Complete is enabled, a window appears where you can specify certain settings, for example, a title or a total for the variable. Complete the options as required or click Cancel. For further information about Active Complete, please refer to article 12640.

You've now added the required variable to your report and should make any further changes you require to the document then save the changes. For further information about how to save the amended document, please refer to the section To save the changes to your document later in this article.

To remove text or variables

  1. Report Designer design page > locate and click the text or variable you want to delete > Delete. Tip: You can also right-click the text or variable and choose Delete.

  2. Repeat step 1 for each text box or variable you want to delete.

You've now removed unwanted text and variables from your report and should make any further changes you require to the document then save the changes. For further information about how to save the amended document, please refer to the following section.

To save the changes to your document

  1. Report menu > Report Properties > Report Name > enter a new name for the document > Report Description > enter a new description for the document > OK.

    Report Designer v1.3 and below - Report Explorer pane > select the document name > Properties pane > Name > enter a new name for the document > Enter.

    Tip: You can check your Report Designer version in Help > About > Application > File Version.

  2. File > Save As > File name > enter a new file name for the document > browse to the required location for your document > Save.
  3. File > Exit.

Tip: If you have any difficulty finding a recently saved document, you can open it from the Report Designer Recent files list and save it to the required location. To open a recently viewed report, from the main program, open the Tools menu, choose Report Designer then from the Recent files list, click your required report.

Answers to common questions

What you've been asking us...

Related documents

Other useful information...

29329 - Report Designer - Dynamic Help

Note: For more information about the many Report Designer features available, take a look at our Report Designer article index.

Steps

Note: If any of the panes mentioned in this section aren't visible, open the View menu and select the required pane. If the pane doesn't appear, you can reset the Report Designer view to its default. For further information about this, please refer to article 27400.

The following steps contain everything you need to help you add and remove text and variables.

To add text

Note: This section explains how to add new text to a document. To edit existing text, locate and select the required text box then press Enter. The cursor appears at the beginning of the text. Edit the text as required then click a blank area outside the text box.

  1. Report Designer > Toolbox menu > Add Text > click the area of the report where you want the new text to appear.

    Report Designer v1.3 and below - Toolbox menu > Textbox > click the area of the report where you want the new text to appear.

    Tip: You can check your Report Designer version in Help > About > Application > File Version.

  2. In the text object box, enter in the text that you want to appear on the report > click a blank area outside the text box.

    Note: The text object box expands as you type, or you can click and drag to specify the space needed by the text box.

You've now added text to your document and should make any further changes required to the document then save the changes. For further information about how to save the amended document, please refer to the section To save the changes to your document later in this article.

To add variables

  1. Report Designer > Variables pane > expand the table you require, for example, SALES_LEDGER > select the Variable you require, for example, ACCOUNT_REF.

    Tip: If you've chosen to auto-hide any of your Report Designer panes, the name appears in a tab to the left or right of your window. To expand a pane, click on its name.

  2. Drag the variable and drop it onto the design in the required position.

    Note: If Active Complete is enabled, a window appears where you can specify certain settings, for example, a title or a total for the variable. Complete the options as required or click Cancel. For further information about Active Complete, please refer to article 12640.

You've now added the required variable to your report and should make any further changes you require to the document then save the changes. For further information about how to save the amended document, please refer to the section To save the changes to your document later in this article.

To remove text or variables

  1. Report Designer design page > locate and click the text or variable you want to delete > Delete. Tip: You can also right-click the text or variable and choose Delete.

  2. Repeat step 1 for each text box or variable you want to delete.

You've now removed unwanted text and variables from your report and should make any further changes you require to the document then save the changes. For further information about how to save the amended document, please refer to the following section.

To save the changes to your document

  1. Report menu > Report Properties > Report Name > enter a new name for the document > Report Description > enter a new description for the document > OK.

    Report Designer v1.3 and below - Report Explorer pane > select the document name > Properties pane > Name > enter a new name for the document > Enter.

    Tip: You can check your Report Designer version in Help > About > Application > File Version.

  2. File > Save As > File name > enter a new file name for the document > browse to the required location for your document > Save.
  3. File > Exit.

Tip: If you have any difficulty finding a recently saved document, you can open it from the Report Designer Recent files list and save it to the required location. To open a recently viewed report, from the main program, open the Tools menu, choose Report Designer then from the Recent files list, click your required report.


Useful links

Answers to common questions

What you've been asking us...

Related documents

Other useful information...

29329 - Report Designer - Dynamic Help

Note: For more information about the many Report Designer features available, take a look at our Report Designer article index.


Watch the video