We use cookies on our website to provide you with the best experience. If you continue browsing, you are consenting to our use of these cookies, but if you would like to know more, including how you can change your settings, take a look at our Privacy Notice.

Installation of Sage Accounts v21 and above is blocked on Windows Small Business Server 2011 (SBS 2011)

Due to a small number of customers seeing performance issues we do not recommend the use of Microsoft Small Business server 2011 (SBS 2011) with Sage Accounts v21 or above. For more information, please refer to article 30792.

We've taken the decision to remove this as one of the recommended operating systems for Sage Accounts v21 and above.

The installation of Sage Accounts v21 and above on SBS 2011 is blocked by default but, if required, it's still possible to install the software by installing Sage Accounts directly from the installation files.

Sage 50 Accounts v24 uses Microsoft .NET Framework 4.6 or above. If you're using Microsoft Exchange on SBS 2011, .NET Framework 4.6 is blocked from installing, therefore you must install .NET Framework 4.7 for Sage 50 Accounts to work.